Project a 3D point orthogonally onto a surface (to find the nearest point).
Throws InvalidOperationException if the projection fails.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2018.1
Syntax
C# |
---|
public void Project(
XYZ point,
out UV uv,
out double distance
) |
Visual Basic |
---|
Public Sub Project ( _
point As XYZ, _
<OutAttribute> ByRef uv As UV, _
<OutAttribute> ByRef distance As Double _
) |
Visual C++ |
---|
public:
void Project(
XYZ^ point,
[OutAttribute] UV^% uv,
[OutAttribute] double% distance
) |
Exceptions
See Also