Obtains the IFC class name associated to a given category id for the current export.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static string GetIFCClassNameByCategory( ElementId catId, ExporterIFC exporterIFC ) |
Visual Basic |
---|
Public Shared Function GetIFCClassNameByCategory ( _ catId As ElementId, _ exporterIFC As ExporterIFC _ ) As String |
Visual C++ |
---|
public: static String^ GetIFCClassNameByCategory( ElementId^ catId, ExporterIFC^ exporterIFC ) |
Parameters
- catId
- Type: Autodesk.Revit.DB..::..ElementId
The category id.
- exporterIFC
- Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
Return Value
The IFC class name. This is an empty string if the element should not be exported because it is not found in the mapping file.
Remarks
IFC class names are affected by the user's entries in the mapping file set for a
given export operation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |