View type where the view-specific shape currently being built will be used
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public DirectShapeTargetViewType ViewType { get; set; } |
Visual Basic |
---|
Public Property ViewType As DirectShapeTargetViewType Get Set |
Visual C++ |
---|
public: property DirectShapeTargetViewType ViewType { DirectShapeTargetViewType get (); void set (DirectShapeTargetViewType value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |