Builds and verifies a view-specific shape representation that would typically be stored in a DirectShape object. Currently limited to curve-based representations for plan and elevation views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2015

Syntax

C#
public class ViewShapeBuilder : ShapeBuilder
Visual Basic
Public Class ViewShapeBuilder _
	Inherits ShapeBuilder
Visual C++
public ref class ViewShapeBuilder : public ShapeBuilder

Remarks

The validation functionality is used by DirectShape to validate the incoming shape.

Inheritance Hierarchy

System..::..Object
  Autodesk.Revit.DB..::..ShapeBuilder
    Autodesk.Revit.DB..::..ViewShapeBuilder

See Also