Set pipe slope values.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public void SetPipeSlopes( IList<double> slopes ) |
Visual Basic |
---|
Public Sub SetPipeSlopes ( _ slopes As IList(Of Double) _ ) |
Visual C++ |
---|
public: void SetPipeSlopes( IList<double>^ slopes ) |
Parameters
- slopes
- Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Pipe slope values. Revit stores the slope value as a percentage (0-100).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Each value of the slopes must be between 0 and 100. Slope value is stored in percentage. e.g. 100 means 100%, and it is 45 degree. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed. |