Cancels the edit scope.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void Cancel() |
Visual Basic |
---|
Public Sub Cancel |
Visual C++ |
---|
public: void Cancel() |
Remarks
All the changes made after starting the EditScope will be rolled back.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | EditScope is not active. EditScope can only be committed or cancelled when it is active. -or- EditScope cannot be closed, for there is a transaction or transaction group still open in the document. |