Retrieves the function of the specified layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public MaterialFunctionAssignment GetLayerFunction( int layerIdx ) |
Visual Basic |
---|
Public Function GetLayerFunction ( _ layerIdx As Integer _ ) As MaterialFunctionAssignment |
Visual C++ |
---|
public: MaterialFunctionAssignment GetLayerFunction( int layerIdx ) |
Parameters
- layerIdx
- Type: System..::..Int32
Index of a layer in the CompoundStructure.
Return Value
The function of the layer.
Remarks
The function determines how this layer interacts with the layers of other elements to which it is joined.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range. |