The tangent vector at the end of the curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public XYZ EndTangent { get; set; } |
Visual Basic |
---|
Public Property EndTangent As XYZ Get Set |
Visual C++ |
---|
public: property XYZ^ EndTangent { XYZ^ get (); void set (XYZ^ value); } |
Field Value
This must be a nomalized unit vector.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: endTangent has zero length. |
Autodesk.Revit.Exceptions..::..InapplicableDataException | The end tangent value is not set. |