Constructs the index buffer with the given capacity, measured in short integers.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public IndexBuffer( int sizeInShortInts ) |
Visual Basic |
---|
Public Sub New ( _ sizeInShortInts As Integer _ ) |
Visual C++ |
---|
public: IndexBuffer( int sizeInShortInts ) |
Parameters
- sizeInShortInts
- Type: System..::..Int32
The number of short integers that the buffer can contain.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This IndexBuffer is not available because Revit is not currently rendering. In general, this IndexBuffer must be used in the scope of the RenderScene() callback of IDirectContext3DServer. |