Checks whether a given cell, i.e. a box aligned with the XYZ axes, is inside, outside
or on the border of the volume of interest.
Namespace: Autodesk.Revit.DB.PointCloudsAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2012
Syntax
C# |
---|
public int TestCell(
XYZ min,
XYZ max
) |
Visual Basic |
---|
Public Function TestCell ( _
min As XYZ, _
max As XYZ _
) As Integer |
Visual C++ |
---|
public:
int TestCell(
XYZ^ min,
XYZ^ max
) |
Return Value
- -1 -- The cell is entirely rejected.
- 0 -- The cell partially belongs to the volume of interest. Use PrepareForCell() and TestPoint() to
evaluate individual points.
- 1 -- The cell is fully accepted.
Exceptions
See Also