Creates a new instance of a bound linear curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
C# |
---|
public static Line CreateBound(
XYZ endpoint1,
XYZ endpoint2
) |
Visual Basic |
---|
Public Shared Function CreateBound ( _
endpoint1 As XYZ, _
endpoint2 As XYZ _
) As Line |
Visual C++ |
---|
public:
static Line^ CreateBound(
XYZ^ endpoint1,
XYZ^ endpoint2
) |
Return Value
The new bound line.
Examples
CopyC#
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 10);
Line line = Line.CreateBound(startPoint, endPoint);
CopyVB.NET
Dim startPoint As New XYZ(0, 0, 0)
Dim endPoint As New XYZ(10, 10, 10)
Dim line__1 As Line = Line.CreateBound(startPoint, endPoint)
Exceptions
See Also