Set the elements whose intersection with path produces points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public void SetIntersectingElements(
	ICollection<ElementId> intersectors
)
Visual Basic
Public Sub SetIntersectingElements ( _
	intersectors As ICollection(Of ElementId) _
)
Visual C++
public:
void SetIntersectingElements(
	ICollection<ElementId^>^ intersectors
)

Parameters

intersectors
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException Not all intersecting elements in intersectors are valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also