Constructs a tessellated face without holes. Face data is always set,
even if the input data are invalid (e.g., describes a wildly non-planar
face). A TessellatedShepeBuilder's function is used to check
the data and heal them if possible.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
C# |
---|
public TessellatedFace(
IList<XYZ> outerLoopVertices,
ElementId materialId
) |
Visual Basic |
---|
Public Sub New ( _
outerLoopVertices As IList(Of XYZ), _
materialId As ElementId _
) |
Visual C++ |
---|
public:
TessellatedFace(
IList<XYZ^>^ outerLoopVertices,
ElementId^ materialId
) |
Parameters
- outerLoopVertices
- Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
Boundary vertices without duplication of the ends - i.e., a
boundary of a triangular face consists of 3 (and NOT 4) vertices.
It is expected that boundaries are in CCW order with respect to
the face normal in the solid. Boundaries in CW order will still
be handled by TessellatedShapeBuilder, but performance may
deteriorate. Contents of this parameter will be changed while
constructing the face.
- materialId
- Type: Autodesk.Revit.DB..::..ElementId
Material of the face to be used when the result is a Solid or a Sheet.
If the result is a Mesh, a material will be assigned to the entire Mesh.
Exceptions
See Also