Checks whether a field can be used with a HasParameter filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public bool CanFilterByParameterExistence( ScheduleFieldId fieldId ) |
Visual Basic |
---|
Public Function CanFilterByParameterExistence ( _ fieldId As ScheduleFieldId _ ) As Boolean |
Visual C++ |
---|
public: bool CanFilterByParameterExistence( ScheduleFieldId^ fieldId ) |
Parameters
- fieldId
- Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.
Return Value
True if the field can be used with a HasParameter filter, false otherwise.
Remarks
The HasParameter filter type only supports shared parameters,
and only with the Instance or ElementType field types.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |