Creates a new opening in a beam, brace and column.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Opening NewOpening( Element famInstElement, CurveArray profile, eRefFace iFace ) |
Visual Basic |
---|
Public Function NewOpening ( _ famInstElement As Element, _ profile As CurveArray, _ iFace As eRefFace _ ) As Opening |
Visual C++ |
---|
public: Opening^ NewOpening( Element^ famInstElement, CurveArray^ profile, eRefFace iFace ) |
Parameters
- famInstElement
- Type: Autodesk.Revit.DB..::..Element
host element of the opening, can be a beam, brace and column.
- profile
- Type: Autodesk.Revit.DB..::..CurveArray
profile of the opening.
- iFace
- Type: Autodesk.Revit.Creation..::..eRefFace
face on which opening is based on.
Return Value
If successful, an Opening object is returned.
Remarks
This method forms opening on a beam, brace and column.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the family instance element does not exist in the given document. |