The filter element to be selected once Show is invoked.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public ElementId FilterToSelect { get; set; } |
Visual Basic |
---|
Public Property FilterToSelect As ElementId Get Set |
Visual C++ |
---|
public: property ElementId^ FilterToSelect { ElementId^ get (); void set (ElementId^ value); } |
Field Value
The default is InvalidElementId, resulting in selecting the first available (if any) FilterElement.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The supplied ElementId id is not of a FilterElement. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |