Allows display of the dialog used to create and edit FilterElements in Autodesk Revit.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public class FilterDialog : IDisposable |
Visual Basic |
---|
Public Class FilterDialog _ Implements IDisposable |
Visual C++ |
---|
public ref class FilterDialog : IDisposable |
Remarks
The class provides the option to launch the dialog by selecting an existing FilterElement,
or automatically creating a new ParameterFilterElement.
In both cases the affected element will be selected for editing.
Note that the user may opt to add, delete or edit any of the available filter elements (or make no changes at all).
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.UI..::..FilterDialog
Autodesk.Revit.UI..::..FilterDialog