Checks that the value is a valid value for this property.
Namespace: Autodesk.Revit.DB.VisualAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.1
Syntax
C# |
---|
public bool IsValidValue( int value ) |
Visual Basic |
---|
Public Function IsValidValue ( _ value As Integer _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidValue( int value ) |
Parameters
- value
- Type: System..::..Int32
The value to be checked.
Return Value
True if the value is valid for the property.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot check validity for a property not being edited in AppearanceAssetEditScope. |