A unique string identifier for DialogBox and TaskDialog type dialogs in Revit.
Namespace: Autodesk.Revit.UI.EventsAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public string DialogId { get; } |
Visual Basic |
---|
Public ReadOnly Property DialogId As String Get |
Visual C++ |
---|
public: property String^ DialogId { String^ get (); } |
Remarks
The contents of this entry vary depending on the type of dialog which is shown:
- DialogBox: A unique string ID that can be used to identify those whihch dialog has been invoked.
- TaskDialog: The customed string if TaskDialog.Id is set, empty string for default TaskDialog.Show(). For Revit-created dialog boxes, this should always have an assigned value.
- Standard Message Boxes: this will be an empty string.