The base class for the event arguments used by the DialogBoxShowing event.
Namespace: Autodesk.Revit.UI.EventsAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2010
Syntax
C# |
---|
public class DialogBoxShowingEventArgs : RevitAPIPreEventArgs |
Visual Basic |
---|
Public Class DialogBoxShowingEventArgs _ Inherits RevitAPIPreEventArgs |
Visual C++ |
---|
public ref class DialogBoxShowingEventArgs : public RevitAPIPreEventArgs |
Remarks
The actual type of the event arguments will be different depending upon the type of dialog shown.
When the application receives this object, a dialog is to be displayed in Revit that
requires user interaction. The OverrideResult function can be used to cause the dialog
to be dismissed and return a desired result code.
Inheritance Hierarchy
System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.UI.Events..::..DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..MessageBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..TaskDialogShowingEventArgs
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.UI.Events..::..DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..MessageBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..TaskDialogShowingEventArgs