Adds a new filter at the specified position in the list.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void InsertFilter( ScheduleFilter filter, int index ) |
Visual Basic |
---|
Public Sub InsertFilter ( _ filter As ScheduleFilter, _ index As Integer _ ) |
Visual C++ |
---|
public: void InsertFilter( ScheduleFilter^ filter, int index ) |
Parameters
- filter
- Type: Autodesk.Revit.DB..::..ScheduleFilter
The filter to add.
- index
- Type: System..::..Int32
The index in the list of filters.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters. -or- The resulting filter count would be greater than 8. |