Change the parameter's value as stored in the definition.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2009
Syntax
C# |
---|
public void SetParameterDefaultValue( ElementId paramId, double value ) |
Visual Basic |
---|
Public Sub SetParameterDefaultValue ( _ paramId As ElementId, _ value As Double _ ) |
Visual C++ |
---|
public: void SetParameterDefaultValue( ElementId^ paramId, double value ) |
Parameters
- paramId
- Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter in the definition.
- value
- Type: System..::..Double
New value for the parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This RebarShapeDefinition does not have a value for the parameter paramId. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |