Reports a bounding box of the geometry that this server submits for drawing.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
Outline GetBoundingBox( View dBView ) |
Visual Basic |
---|
Function GetBoundingBox ( _ dBView As View _ ) As Outline |
Visual C++ |
---|
Outline^ GetBoundingBox( View^ dBView ) |
Parameters
- dBView
- Type: Autodesk.Revit.DB..::..View
The view where rendering will occur. If this argument is nullNothingnullptra null reference (Nothing in Visual Basic), a view-independent bounding box should be reported.
Return Value
The bounding box as an Outline.
Remarks
Revit uses the bounding box when navigating views, e.g., when a Zoom to Fit command is issued. The reported bounding box does not have to be tight. However, there may be unintended side-effects if the box is inconsistent with the submitted geometry.