Specify whether a particular grid node is
interior to the surface, on the boundary, or outside
the boundary.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public GridNodeLocation GetGridNodeLocation( GridNode gridNode ) |
Visual Basic |
---|
Public Function GetGridNodeLocation ( _ gridNode As GridNode _ ) As GridNodeLocation |
Visual C++ |
---|
public: GridNodeLocation GetGridNodeLocation( GridNode gridNode ) |
Parameters
- gridNode
- Type: Autodesk.Revit.DB..::..GridNode
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ]. |