Removes any attachment of the column to the specified target.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static void RemoveColumnAttachment( FamilyInstance column, ElementId targetId ) |
Visual Basic |
---|
Public Shared Sub RemoveColumnAttachment ( _ column As FamilyInstance, _ targetId As ElementId _ ) |
Visual C++ |
---|
public: static void RemoveColumnAttachment( FamilyInstance^ column, ElementId^ targetId ) |
Parameters
- column
- Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
- targetId
- Type: Autodesk.Revit.DB..::..ElementId
Id of a target element.
Remarks
This method modifies both column and target elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |