Validates the incoming view type. As of today, the only allowed view type is Plan.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static bool ValidateViewType( DirectShapeTargetViewType targetViewType ) |
Visual Basic |
---|
Public Shared Function ValidateViewType ( _ targetViewType As DirectShapeTargetViewType _ ) As Boolean |
Visual C++ |
---|
public: static bool ValidateViewType( DirectShapeTargetViewType targetViewType ) |
Parameters
- targetViewType
- Type: Autodesk.Revit.DB..::..DirectShapeTargetViewType
Return Value
True if %targetViewType% is DirectShapeTargetViewType::Plan
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |