Implement this method to check if the given instance represents a valid server of this service.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
bool IsValidServer( IExternalServer server ) |
Visual Basic |
---|
Function IsValidServer ( _ server As IExternalServer _ ) As Boolean |
Visual C++ |
---|
bool IsValidServer( IExternalServer^ server ) |
Parameters
- server
- Type: Autodesk.Revit.DB.ExternalService..::..IExternalServer
An instance of a server that is to be validated.
Return Value
True if the server is valid, False otherwise
Remarks
This method is invoked by the framework upon registration of a server for this service.
The simplest implementation would be to test whether the type of the object is as expected,
but a service may have other rules for validating its servers.