Determines whether given coordinates are within the bounds.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool AreCoordinatesInBounds( RepeaterCoordinates coordinates, bool treatCyclicalBoundsAsInfinite ) |
Visual Basic |
---|
Public Function AreCoordinatesInBounds ( _ coordinates As RepeaterCoordinates, _ treatCyclicalBoundsAsInfinite As Boolean _ ) As Boolean |
Visual C++ |
---|
public: bool AreCoordinatesInBounds( RepeaterCoordinates^ coordinates, bool treatCyclicalBoundsAsInfinite ) |
Parameters
- coordinates
- Type: Autodesk.Revit.DB..::..RepeaterCoordinates
The coordinates.
- treatCyclicalBoundsAsInfinite
- Type: System..::..Boolean
True if cyclical directions should be treated as unbounded.
Return Value
True if the coordinates are within the bounds.
Remarks
The coordinates must have the same number of dimensions as the bounds.
This method does not apply to zero dimensional bounds.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The coordinates coordinates have incompatible number of dimensions. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The bounds must have at least one dimension. |