Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public void SetDatumExtentType( DatumEnds datumEnd, View view, DatumExtentType extentMode ) |
Visual Basic |
---|
Public Sub SetDatumExtentType ( _ datumEnd As DatumEnds, _ view As View, _ extentMode As DatumExtentType _ ) |
Visual C++ |
---|
public: void SetDatumExtentType( DatumEnds datumEnd, View^ view, DatumExtentType extentMode ) |
Parameters
- datumEnd
- Type: Autodesk.Revit.DB..::..DatumEnds
Specifies one end of the curve representing the datum plane in the view.
- view
- Type: Autodesk.Revit.DB..::..View
The view in which to set the datum extent settings.
- extentMode
- Type: Autodesk.Revit.DB..::..DatumExtentType
The DatumExtentType.
Remarks
In a particular view, the datum plane is represented by a curve and the two ends of the curve may have different DatumExtentTypes in that view.
If the value is changed from DatumExtentType::Model to DatumExtentType::ViewSpecific, then the view specific extents will be identical to the model
extent until modified.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |