Sets the element that has caused the failure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public FailureMessage SetFailingElement( ElementId id ) |
Visual Basic |
---|
Public Function SetFailingElement ( _ id As ElementId _ ) As FailureMessage |
Visual C++ |
---|
public: FailureMessage^ SetFailingElement( ElementId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..ElementId
The element that has caused the failure.
Return Value
The FailureMessage.
Remarks
In Revit error dialog this element will be highlighted to the user and can be deleted by user via extended error dialog.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessage is already posted to a document |