Represents a message describing a failure of an operation in Revit.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public class FailureMessage : IDisposable |
Visual Basic |
---|
Public Class FailureMessage _ Implements IDisposable |
Visual C++ |
---|
public ref class FailureMessage : IDisposable |
Remarks
Failure messages are typically shown to the user in the Revit error dialog.
This class contains the following information about the failures:
- The basic description of the failure (retrieved from the FailureDefinition)
- The available resolutions for the failure.
- The elements related to the failure.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..FailureMessage
Autodesk.Revit.DB..::..FailureMessage