Whether or not the geometry stored in a DirectShape object may be referenced.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public DirectShapeReferencingOption ReferencingOption { get; set; } |
Visual Basic |
---|
Public Property ReferencingOption As DirectShapeReferencingOption Get Set |
Visual C++ |
---|
public: property DirectShapeReferencingOption ReferencingOption { DirectShapeReferencingOption get (); void set (DirectShapeReferencingOption value); } |
Field Value
The default value is Referenceable.
Remarks
If the geometry is not referenceable, it may not be used for dimensioning, snapping, alingment, or face-hosting.
The element may still be selected by the user for operations which do not reference individual geometry objects.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |