Set legend settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2011

Syntax

C#
public void SetLegendSettings(
	AnalysisDisplayLegendSettings legendSettings
)
Visual Basic
Public Sub SetLegendSettings ( _
	legendSettings As AnalysisDisplayLegendSettings _
)
Visual C++
public:
void SetLegendSettings(
	AnalysisDisplayLegendSettings^ legendSettings
)

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also