Contains legend settings for analysis display style element.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public class AnalysisDisplayLegendSettings : IDisposable |
Visual Basic |
---|
Public Class AnalysisDisplayLegendSettings _ Implements IDisposable |
Visual C++ |
---|
public ref class AnalysisDisplayLegendSettings : IDisposable |
Examples

AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings(); legendSettings.NumberOfSteps = 10; legendSettings.Rounding = 0.05; legendSettings.ShowDataDescription = false; legendSettings.ShowLegend = true;

Dim legendSettings As New AnalysisDisplayLegendSettings() legendSettings.NumberOfSteps = 10 legendSettings.Rounding = 0.05 legendSettings.ShowDataDescription = False legendSettings.ShowLegend = True
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings