Obtains the IFC class name associated to the given element for the current export.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static string GetIFCClassName( Element element, ExporterIFC exporterIFC ) |
Visual Basic |
---|
Public Shared Function GetIFCClassName ( _ element As Element, _ exporterIFC As ExporterIFC _ ) As String |
Visual C++ |
---|
public: static String^ GetIFCClassName( Element^ element, ExporterIFC^ exporterIFC ) |
Parameters
- element
- Type: Autodesk.Revit.DB..::..Element
The element.
- exporterIFC
- Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
Return Value
The IFC class name. This is an empty string if the element should not be exported because it is not found in the mapping file.
Remarks
IFC class names are affected by the user's entries in the mapping file set for a
given export operation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |