Checks that the building type falls within an appropriate range.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static bool CheckBuildingType( gbXMLBuildingType buildingType ) |
Visual Basic |
---|
Public Shared Function CheckBuildingType ( _ buildingType As gbXMLBuildingType _ ) As Boolean |
Visual C++ |
---|
public: static bool CheckBuildingType( gbXMLBuildingType buildingType ) |
Parameters
- buildingType
- Type: Autodesk.Revit.DB.Analysis..::..gbXMLBuildingType
The building type to be checked.
Return Value
True if the building type falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |