Checks whether the name is a valid short name for the external resource server.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static bool IsValidShortName( Guid serverId, string serverName ) |
Visual Basic |
---|
Public Shared Function IsValidShortName ( _ serverId As Guid, _ serverName As String _ ) As Boolean |
Visual C++ |
---|
public: static bool IsValidShortName( Guid serverId, String^ serverName ) |
Parameters
- serverId
- Type: System..::..Guid
The id of the external resource server.
- serverName
- Type: System..::..String
The short name of the external resource server.
Return Value
True if the name is a valid short name, false otherwise.
Remarks
A valid short name should match the restrictions documented in GetShortName()()()().
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |