Implement this method to return the short name of the server.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
string GetShortName() |
Visual Basic |
---|
Function GetShortName As String |
Visual C++ |
---|
String^ GetShortName() |
Return Value
The short name of the server.
Remarks
The name is a unique path prefix included in full paths to external resources provided by this server.
It is recommended that the short name length is at least 3 characters to make it useful for
users to identify the server easily.
To ensure the server can be registered successfully, the name should match restrictions below:
- The name cannot be empty or consist of only whitespace characters.
- The name should not include any invalid characters such as \/:*?"<>|.
- The name cannot duplicate any other external resource server names.
- The name should not duplicate a Revit reserved path prefix(case insensitive), including: RSN, A360, buzzsaw, vault, redspark, ftp, http, https, files, file.