Creates new rooms in each plan circuit found in the given level in the last phase.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public ICollection<ElementId> NewRooms2( Level level ) |
Visual Basic |
---|
Public Function NewRooms2 ( _ level As Level _ ) As ICollection(Of ElementId) |
Visual C++ |
---|
public: ICollection<ElementId^>^ NewRooms2( Level^ level ) |
Parameters
- level
- Type: Autodesk.Revit.DB..::..Level
The level from which the circuits are found.
Return Value
If successful, a set of ElementIds which contains the rooms created should be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation. |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the level does not exist in the given document. |