Checks if an element has associated parts.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static bool HasAssociatedParts( Document hostDocument, LinkElementId hostOrLinkElementId ) |
Visual Basic |
---|
Public Shared Function HasAssociatedParts ( _ hostDocument As Document, _ hostOrLinkElementId As LinkElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool HasAssociatedParts( Document^ hostDocument, LinkElementId^ hostOrLinkElementId ) |
Parameters
- hostDocument
- Type: Autodesk.Revit.DB..::..Document
The document.
- hostOrLinkElementId
- Type: Autodesk.Revit.DB..::..LinkElementId
The element to be checked for associated Parts.
Return Value
True if the element has associated Parts.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |