The system classification of the connector.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public MEPSystemClassification SystemClassification { get; set; } |
Visual Basic |
---|
Public Property SystemClassification As MEPSystemClassification Get Set |
Visual C++ |
---|
public: property MEPSystemClassification SystemClassification { MEPSystemClassification get (); void set (MEPSystemClassification value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: The MEPSystemType is not valid for the domain of this connector. |