Sets the distance from the RebarConstrainedHandle to the target Host Cover Element surface. The RebarConstraintType of the RebarConstraint must be 'ToCover.'

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2016

Syntax

C#
public void SetDistanceToTargetCover(
	double distanceToTargetCover
)
Visual Basic
Public Sub SetDistanceToTargetCover ( _
	distanceToTargetCover As Double _
)
Visual C++
public:
void SetDistanceToTargetCover(
	double distanceToTargetCover
)

Parameters

distanceToTargetCover
Type: System..::..Double
The distance is given as an offset value, the sign of which depends on Host Cover direction.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException The given value for distanceToTargetCover must be no more than 30000 feet in absolute value.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToCover.'

See Also