Inserts a (key, info) pair into Export line type table.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void Add( ExportLinetypeKey exportLinetypeKey, ExportLinetypeInfo exportLinetypeInfo ) |
Visual Basic |
---|
Public Sub Add ( _ exportLinetypeKey As ExportLinetypeKey, _ exportLinetypeInfo As ExportLinetypeInfo _ ) |
Visual C++ |
---|
public: void Add( ExportLinetypeKey^ exportLinetypeKey, ExportLinetypeInfo^ exportLinetypeInfo ) |
Parameters
- exportLinetypeKey
- Type: Autodesk.Revit.DB..::..ExportLinetypeKey
The export line type Key to be added.
- exportLinetypeInfo
- Type: Autodesk.Revit.DB..::..ExportLinetypeInfo
The export line type info to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The key already exists in the table. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |