Identifies if the section type is valid for this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool IsValidSectionType( SectionType sectionType ) |
Visual Basic |
---|
Public Function IsValidSectionType ( _ sectionType As SectionType _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidSectionType( SectionType sectionType ) |
Parameters
- sectionType
- Type: Autodesk.Revit.DB..::..SectionType
The section type.
Return Value
True if the Section Type is valid, false otherwise.
Remarks
Some TableViews do not contain all of the possible section types. For
example, standard schedules have only a Heading and Body.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |