Looks up an existing fabrication part type based on a specfic fabrication service button and condition.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public static ElementId Lookup( Document document, FabricationServiceButton button, int condition ) |
Visual Basic |
---|
Public Shared Function Lookup ( _ document As Document, _ button As FabricationServiceButton, _ condition As Integer _ ) As ElementId |
Visual C++ |
---|
public: static ElementId^ Lookup( Document^ document, FabricationServiceButton^ button, int condition ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- button
- Type: Autodesk.Revit.DB..::..FabricationServiceButton
The fabrication service button.
- condition
- Type: System..::..Int32
The condition index.
Return Value
Identifier of the fabrication part type element or invalidElementId if no fabrication part type exist for the specific fabrication service button and condition
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index condition is not larger or equal to 0 and less than ConditionCount |