Represents a fabrication component type in the Autodesk Revit MEP product.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public class FabricationPartType : ElementType |
Visual Basic |
---|
Public Class FabricationPartType _ Inherits ElementType |
Visual C++ |
---|
public ref class FabricationPartType : public ElementType |
Remarks
For the product-based MAP parts, every size is a new part type in Revit. For others, one part type can have many sizes.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..FabricationPartType
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..FabricationPartType