Check that value is valid.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2018.1

Syntax

C#
public bool IsValidValue(
	IList<AssetProperty> value
)
Visual Basic
Public Function IsValidValue ( _
	value As IList(Of AssetProperty) _
) As Boolean
Visual C++
public:
bool IsValidValue(
	IList<AssetProperty^>^ value
)

Parameters

value
Type: System.Collections.Generic..::..IList<(Of <(<'AssetProperty>)>)>
The array of properties to validate.

Return Value

Returns true if the array of properties is valid, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException Cannot check validity for a property not being edited in AppearanceAssetEditScope.

See Also