Returns References to Faces from MassZones coincident with an input Face from a
MassEnergyAnalyticalModel.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static IList<Reference> GetCoincidentMassZoneFaceReferences( Document document, Reference referenceToFace ) |
Visual Basic |
---|
Public Shared Function GetCoincidentMassZoneFaceReferences ( _ document As Document, _ referenceToFace As Reference _ ) As IList(Of Reference) |
Visual C++ |
---|
public: static IList<Reference^>^ GetCoincidentMassZoneFaceReferences( Document^ document, Reference^ referenceToFace ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The Document.
- referenceToFace
- Type: Autodesk.Revit.DB..::..Reference
A Reference to a Face of a MassEnergyAnalyticalModel.
Return Value
Returns References to Faces from MassZones coincident with an input Face from a MassEnergyAnalyticalModel.
Remarks
The results are always References to Faces. The Reference Type should report as REFERENCE_TYPE_SURFACE.
Currently Revit improperly reports it as REFERENCE_TYPE_NONE.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The Reference is not a Face of a MassEnergyAnalyticalModel. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |