The restore defaults handler.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public TabbedDialogAction OnRestoreDefaultsAction { get; set; } |
Visual Basic |
---|
Public Property OnRestoreDefaultsAction As TabbedDialogAction Get Set |
Visual C++ |
---|
public: property TabbedDialogAction^ OnRestoreDefaultsAction { TabbedDialogAction^ get (); void set (TabbedDialogAction^ value); } |
Remarks
This handler will be invoked when the "Restore Defaults" button in Revit options dialog is clicked
and the handler should apply only to options set on this page.
There is no "Restore Defaults" button in Revit options dialog if this property was set to nullNothingnullptra null reference (Nothing in Visual Basic).