Associates the specified CoverType with the specified face of the element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetCoverType( Reference face, RebarCoverType coverType ) |
Visual Basic |
---|
Public Sub SetCoverType ( _ face As Reference, _ coverType As RebarCoverType _ ) |
Visual C++ |
---|
public: void SetCoverType( Reference^ face, RebarCoverType^ coverType ) |
Parameters
- face
- Type: Autodesk.Revit.DB..::..Reference
- coverType
- Type: Autodesk.Revit.DB.Structure..::..RebarCoverType
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | In this element, face does not have an associated CoverType, because it is not exposed. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |